Company Christmas Holidays
North American Headquarters in Miami, USA: Dec 25, 2015, Jan 1st 2016
European Headquarters in Muenster, Germany: Dec 21, 2015 until Jan 03rd 2016
Limited support is available during this period.
We at PROVISIO wish you Merry Christmas and a Happy New Year!

 

Archive: TV Tuner ActiveX control works when loggin in as Restricted User, but not Autostart

Description

Hi,

We are using a custom ActiveX control for our TV tuner application. The html file that loads the ActiveX also contains a relative path to the filter graph that the ActiveX control loads. In this case, both the control and graph are in the same directory.

When I enable autostart/shell replacement for the restricted SiteKiosk user, the control will not load properly. The area occupied by the control does not refresh and shows the contents of the window behind it.

When I disable autostart/shell replacement and login as the SiteKiosk restricted user and then run SiteKiosk manually, the control works fine.

In both cases the SiteKiosk user has been locked down using the SiteKiosk Security Manager application. What difference would there be that would allow me to run the control when Shell Replacement is disabled but im still using the restricted account?

Réponse: (1)

Re: TV Tuner ActiveX control works when loggin in as Restricted User, but not Autostart 29/06/2006 20:06
I have a little more information on this problem. I was fiddling with the startup options and found my problem is related to the shell replacement part of the auto start/login function.

If I choose auto-start and auto-login with the restricted user, but not shell replacement, the tuner control will work.

I also found that if I choose auto-start and shell replacement but not auto-login, then login as an administrator user, the tuner control won't work. Even though this user has complete control over the system!

So there seems to be some issue between our tuner control and shell replacement. Is there more to shell replacement than just replacing explorer.exe with 'sitekiosk.exe <config file path>'??